User forum for all things Toyota Entune

It is currently Thu May 23, 2019 8:12 pm

All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Audio Selection Issues
PostPosted: Sun Apr 21, 2019 2:24 pm 

Joined: Sun Apr 21, 2019 1:50 pm
Posts: 2
I have a Toyota Kluger (Highlander) 2018 GXL model.

I have an issue regarding USB default mode.

Whenever I start the car, the audio system defaults to Folder mode.
In Folder mode, instead of showing the Track Title using the ID3 Tag, it instead shows the filename.

The situation for me, is that for well over a decade, I have named my files with the 8.3 naming convention, to give broadest support. Those short names also use less memory.
Long ago, I developed a formula for an Abbreviation program I created, that uses first 3 letters of artist name, followed by next 3 letters of album/single/ep name, followed by 2 zero based digits for track number.
i.e. ELJYBR01.mp3
Which stands for ELTON JOHN - Yellow Brick Road - Track 01
I embed the artwork and all other relevant ID3 Tag information inside each MP3 (i.e. Track Title, Artist Name, Album Title, Track Number, Year, Genre, Comment).

Because of the two digit number coming last, all tracks for the same artist/album sort correctly. That means they usually play correctly, not requiring the use of embedded Track Numbers to do so.

The problem I have, because the car player always defaults to Folder mode, is that I do not see the Track Title, unless I step through several selections, involving changing to either Artist or Album mode. This means, selecting artist, then album, then track ... remembering of course, what the correct number of the current track is to avoid a change of track. This involves a lot of browsing and scrolling most of the time. And of course I cannot even attempt to browse, until the BROWSE button becomes available ... which means starting the car and hanging around waiting ... or being naughty, and doing selections while driving.

That is a lot of clicks and quite annoying and frustrating and even dangerous.
If the player can remember the last track played, why cannot it remember the last Mode as well, and restore that?
And why can I not seemingly set another Mode as default? i.e. Album Mode.

In Artist or Album modes, the Track Title is read from embedded ID3 Tag data.

Yes, I could rename the filename of all my tracks, to match the Track Title, though there is a length limit. Indeed, I have done that on one of my USB drives. However, quite onerous to rename several thousand MP3s.

And that does not solve everything, because sometimes, regardless of Track Numbers existing, album tracks sometimes play out of order. That usually occurs mid album after the car has been turned off and back on again. For some reason, the player then defaults to what I guess is alphanumeric mode. My 8.3 naming convention which includes track number at the end, would solve this issue.

So what I would much prefer to do, is change the default mode away from Folder mode, to Album mode.
Can this be done?

Is there maybe some secret access code or some power user mode to change some defaults?


Top
 Profile  
 
 Post subject: Re: Audio Selection Issues
PostPosted: Tue May 07, 2019 7:32 pm 

Joined: Sun Apr 21, 2019 1:50 pm
Posts: 2
The mind boggles, that in 2019 we are still having these b-grade types of media issues.

What bright spark thought ID3 Tags shouldn't be the default read mode?

Why in hell would you set Folder and filename as the default read mode?

Users should be encouraged to use ID3 Tags, not catered for if they don't.
They can always learn to use them, and overcome their ignorance.
Whereas if Folder mode is the default and the default cannot be changed, then we are stuck with a dumb situation.

What the hell is the point of even supporting ID3 Tags, if you have to continually browse to use them every time you start the car? It is just not user friendly or intuitive to have Folder mode as the default.

And how many users are in danger, because they risk setting the system into Album or Artist mode for ID3 Tags, once they have started driving, because Browse is not immediately available.

I have this great modern car, with a b-grade Audio System from the 80s.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group